Module 1 - Basics of Simulation

Visual Components 4.1 | Version: May 15, 2018

In this module you learn the basics of using a Visual Components 4.1 product. For example, you learn how to install and license a 4.1 product, access Help files, and work with components and layouts in the 3D world.

You will also have the opportunity to create several files that can be used to present, visualize and document a machine tending operation. These include:

- Images of a simulation
- 3D PDF of a recorded simulation
- Video of a recorded simulation
- 3D and virtual reality animation of a recorded simulation
- 2D technical drawings of components to scale and bill of materials
- Charts and data files for statistics generated during a simulation

Support
support@visualcomponents.com

Forum
forum.visualcomponents.com
# Contents

Getting Started ........................................................................................................................................... 3

- Installation and Setup ................................................................................................................................. 3
- Help .............................................................................................................................................................. 4
- eCatalog ....................................................................................................................................................... 5
- Preferences .................................................................................................................................................. 6

Basic Controls .................................................................................................................................................. 7

Manipulation Controls ................................................................................................................................... 9

- Selection ..................................................................................................................................................... 9
- Movement .................................................................................................................................................. 10
- Plug and Play ............................................................................................................................................. 11
- Interaction .................................................................................................................................................. 12

Simulation Controls ....................................................................................................................................... 13

Recording Controls ....................................................................................................................................... 15

- Images ..................................................................................................................................................... 15
- 3D PDF .................................................................................................................................................... 16
- Animations ................................................................................................................................................ 18
- Videos ...................................................................................................................................................... 19

Drawing Controls ......................................................................................................................................... 23

- Drawings .................................................................................................................................................. 24
- Dimensions ............................................................................................................................................... 26
- Annotations .............................................................................................................................................. 28
- Printing ................................................................................................................................................... 29

Statistics Dashboard ..................................................................................................................................... 30

Review ......................................................................................................................................................... 35
Getting Started

Installation and Setup

1. Download and run the installer for your Visual Components 4.1 product.

2. Use the Wizard to complete installation.

3. Run your Visual Components 4.1 product.

4. Use the Activation guide to license the software and start using it.
Help

1. Click the **Help** tab. This displays commands on the Ribbon for accessing offline and online help material.

![Help tab screenshot](image)

2. Do any of the following:

   - To access the Help file, press F1 or in Help and Reference, click **Help**. It is recommended to review the "Getting Started > How It Works” section. Refer to the "User Interface" section as needed. The "Tasks" section contains mini tutorials or how-to articles.

   - To access online lessons and courses, in Online Support Material, click **Academy**. This will open a web browser and take you to the Visual Components Academy. It is recommended to complete the "Getting Started" course as well as subscribe to the Academy to receive notifications.

   - To ask questions, find answers, and discuss Visual Components products, in Online Support Material, click **Forum**. This will open a web browser and take you to the Visual Components Forum. It is recommended to register an account in order to upload and download attachments as well as start and reply to threads. If you are a Visual Components partner, please register an account with your work email address, and then send an email to support@visualcomponents.com which indicates your username. This will unlock the partner area of the forum for your account.

   - To submit a support ticket, in Online Support Material, click **Community**. This will open a web browser and take you to the Visual Components Community. The login for the Community is the same one for the Visual Components License Portal. It is recommended to register an account to create and access support tickets as well as manage licenses. If you do not have a valid maintenance agreement, you can still submit a support ticket by emailing support@visualcomponents.com.
eCatalog

To have access to the Visual Components Web eCatalog, a library of components and layouts, your computer must allow traffic from your Visual Components 4.1 product. The eCatalog panel acts like a web browser, so it uses HTTP (port 80).

1. Click the **Home** tab. This displays a view for building a layout and running simulations in the 3D world.

2. In the eCatalog panel, Collections view, expand **Public Models**. This is your main source of components and layouts. It is linked to a folder in your Public Documents and contains a local copy of the Visual Components Web eCatalog. By default, the local copy executes a daily task to sync with the online library.

3. Expand **Models by Type**. This is a smart collection that filters and groups items using metadata, which are properties used to describe files. Models by Type groups items first by type and then by manufacturer. Models by Manufacturer groups items first by manufacturer and then by type. Both smart collections are hard-coded and reference the eCatalog 4.1 source in your Public Models.
Preferences

You have options for changing the look and feel of a Visual Components 4.1 product.

1. Click the File tab. This displays a Backstage view for managing files and editing options.

2. On the Navigation bar, click Options.

3. In General options, make any needed changes. For example, you can use a different language and theme for the user interface.

4. In Display options, make any needed changes. For example, you can change the color of the floor and background of the 3D world as well as hide its grid.

5. At the lower-right corner, do one of the following:
   - To save your changes, click OK.
   - To not save your changes, click Cancel.

**NOTE!** Some changes may require you to restart your Visual Components 4.1 product.
Basic Controls

Generally, you would use a mouse and keyboard with a Visual Components 4.1 product.

1. In the eCatalog panel, Collections view, under Models by Type, click **Demo Layouts**.

2. In the Display area, Search box, type **machine** to find an item matching that keyword, and then double-click the item to load it in the 3D world. This opens a saved layout of components.

3. In the 3D world, click the **robot** to select it. A selection is outlined and its attributes are displayed in the Properties panel.

4. Hold down CTRL and then click a **machine** to add it to the selection. If selected objects have common properties, you can edit them as long as their values do not need to be unique. For example, Name is a default property with a unique value.

5. Now, hold down CTRL and click the **machine** again to remove it from the selection.
6. On the 3D world toolbar, click **Fill Selected** to fill your view with the selected robot.

![Fill Selected](image)

7. In the viewport, do any of the following to interact with the camera:

   ▪ To rotate the camera, hold down the right mouse button (RMB).

   ▪ To pan the camera, hold down the left and right mouse buttons (LMB+RMB).

   ▪ To zoom the camera, rotate the mouse wheel. You can also hold down SHIFT and the right mouse button (SHIFT+RMB).

   ▪ To center the camera on an object, hold down CTRL and then right-click the object. You can also right-click the object, and then click **Center in 3D View**.

   ▪ To use a standard view, at the lower-left corner, on the View Selector, click a **face**, **edge** or **vertex**.
Manipulation Controls

The Manipulation group on the Ribbon contains different modes for manipulating objects. This depends on the context of the scene. When the Home tab is active, for example, you have the option to select, move, connect and interact with components.

Selection

The Select command only selects objects in the current context, for example components in the 3D world.

1. On the Home tab, in the Manipulation group, click Select.

2. In the 3D world, drag the pointer to make an area selection around components.

3. Click the floor or an empty space to clear the selection.
Movement

The Move command displays an all-in-one tool for moving selected objects. The arrows are for moving a selection along an axis. The squares are for moving a selection in a plane formed by two axes. The arcs are for rotating a selection around an axis. The ring is for snapping a selection to another object.

1. In the Cell Graph panel, Machine Tending category, click Process ProLathe to select the component in the 3D world.

2. On the Home tab, in the Manipulation group, click Move. This displays the Move tool at the origin of the selection, which in this case is the origin of the machine.

3. In the 3D world, drag the blue square to move the machine in its XY plane.

4. Press CTRL+Z to undo the last action, thereby returning the machine to its previous location.
Plug and Play

The PnP command is used to plug components into one another. This is known as a physical connection, and the plugs are known as interfaces. A selected component shows its interfaces as yellow or green arrows. Yellow indicates an available connection. Green indicates an active connection. The interfaces of components need to be compatible in order to plug into one another. When you plug a component into another component, they snap together at the connected interfaces.

1. In the 3D world, select the Wheel Feeder. Remember, you can find and select the component in the Cell Graph panel.

2. On the Home tab, in the Manipulation group, click PnP. This displays a ring around the feeder, which you can use to rotate the component in place. Generally, the ring is used to help connect intended interfaces and deal with angle and distance tolerances for establishing connections.

3. In the 3D world, drag the feeder away from its adjacent conveyor to unplug those components. The PnP command allows you to freely move a selected component.

4. Now, drag the feeder toward the conveyor until a green arrow points from the interface of the feeder to a compatible connection, the available interface of the conveyor.

5. Continue to drag the feeder in the direction of the green arrow until the feeder snaps and connects to the conveyor.
Interaction

The Interact command is used to jog or move interactive parts of components. For example, you can interact with the joints of a robot.

1. In the 3D world, select the robot.

2. On the Home tab, in the Manipulation group, click Interact. The pointer will change to a hand icon when you hover over an interactive part in the 3D world.

3. In the 3D world, interact with the joints of the robot. By default, joint limits are not enforced nor are exceeded limits indicated in the 3D world.

4. Click the Program tab. This displays a view for programming robots.

5. On the Program tab, in the Limits group, select the Color Highlight and Stop at limits check boxes. Color Highlight will use a red material to highlight parts of components exceeding a limit. Stop at limits will enforce limits as well as stop a running simulation so you can troubleshoot an exceeded limit.

6. On the Program tab, in the Manipulation group, click Jog. This is similar to the Interact command but is used to select and teach a robot. This is also why the Move tool is now at the end of the robot arm and located at the active tool center point of the robot.

7. Repeat step 3 until you notice a joint stops moving once it reaches a limit.
Simulation Controls

At the top of the viewport are controls for running and recording simulations in the 3D world.

The Play button can start and stop a simulation. The Reset button returns a simulation to its initial state and time of zero. The Speed factor and slider manage how fast to run a simulation.

1. On the Simulation controls, click **Reset**. This returns all components to their initial state. For example, the joints of the robot are reset to their initial values. By default, the initial state of components is saved at the start of simulation and every time you click Save State.

2. On the Simulation controls, click **Run**. During a simulation, components like the Wheel Feeder make new components. These new components are dynamic and only exist in the simulation. The wheels from the feeder move onto its adjacent conveyor because the feeder and conveyor are connected to one another and have paths for containing and moving other components. This is known as a flow.

3. On the Simulation controls, speed up or slow down the simulation, and then double-click the slider thumb to reset the speed factor to 1.0.

4. On the Simulation controls, click **Reset**. The wheels disappear because they were dynamic, whereas other components like the robot remain because they are static.
There are two modes for running a simulation: real time and virtual time. Real time scales a simulation to mimic time in the real world. Virtual time allows you to run a simulation as fast as your machine will allow it.

5. On the Simulation controls, click the **Gear** icon to access simulation settings.

6. In Simulation Mode, click **Virtual Time**.

7. Run the simulation to verify the difference between real time and virtual time, and then reset the simulation.

By default, a simulation has an infinite runtime, but you can click Custom to set a runtime. Warm Up Time can be used to define a time to start a simulation. Repeat allows you to loop a simulation with a custom runtime.

8. Access the simulation settings.

9. In Simulation Run Time, click **Custom**, and then set the runtime to 2 minutes, which is about how long it takes the components in the 3D world to complete one full cycle of a machine tending process.

10. Run the simulation until it stops, and then reset the simulation.
Recording Controls

You have several options for recording a simulation.

Images

The Export Image command allows you to capture images of the 3D world. Generally, you would export images at the start and end of a simulation as well as other key moments.

1. On the Home tab, in the Export group, click **Image**. This displays a task pane of properties for executing the command as well as a red boundary in the viewport. Anything inside the boundary will be captured in the image, except for layer items like the simulation controls and View Selector.

2. In the 3D world, select the **robot** and then fill your view with it.

3. (Optional) If you are experiencing a delay, it might be caused by the render mode of the 3D world. By default, render mode is Realistic shaded when exporting images. In the Export Image task pane, set Render mode to **Shaded**. You can always change the render mode to a higher setting once you have the intended view.

4. In the Export Image task pane, click **Export** and then save the image. The end result should resemble the following image.

5. Press ESC or click **Close** to exit the Export Image command.
3D PDF

The Export to PDF command allows you to create a 3D PDF. The PDF includes a 3D animation of a recorded simulation as well as a bill of materials (BOM) listing components in the layout.

1. Click the **File** tab to go backstage, and then access **Display** options.

2. Under 3D PDF options, click **Background color**, and then either keep the default color, choose a predefined color or make a new color. This defines the background color of the 3D window for an exported PDF. If you changed the color, remember to click **OK**. Otherwise, click **Cancel**.

3. Press CTRL+A to select all components in the 3D world. When exporting a simulation to a 3D PDF, pay close attention to the BOM and PDF Export Level properties of components. BOM defines if a component is listed in a bill of materials. PDF Export Level defines if and at what level a component is exported to a PDF. For example, you could export the entire component, its bound boxes or nothing at all.
4. On the Simulation controls, click **Export to PDF**.

5. In the Export to PDF task pane, set Title to **Machine Tending Demo**, and then click **Start Recording**.

![Export to PDF](image)

6. Save the file, which will immediately start the simulation and the recording. If you stop the simulation, the recording will end and generate the 3D PDF.

7. Wait for the simulation to stop at two minutes. The 3D PDF will be automatically generated and opened for you. The end result should resemble the following image. Notice not all components are listed in the bill of materials.

![Machine Tending Demo](image)

**NOTE!** By default, 3D content is not played in a PDF. To fix this, you need to enable playing of 3D content in the PDF reader.
Animations

The Export to Animation command allows you to record a simulation as an animation. The animation can be played back in Visual Components Experience, an app for viewing 3D content and experiencing virtual reality. 3D viewing can be done with both mobile and desktop versions of Experience. Virtual reality can be done using HTC Vive and SteamVR with the desktop version.

1. Reset the simulation, and then on the Simulation controls, click Export to Animation.
2. In the Export to Animation task pane, click Start Recording.
3. Save the file, and then wait for the simulation to end.
4. If Visual Components Experience is installed on your device, double-click the animation file to open it, and then click Launch 3D. The end result should resemble the following image.
Videos

The Export to Video command allows you to record a simulation as a video. This means camera movements, lighting, and rendering of components are captured in the recording. Before you record a simulation, it helps to create views and camera movements for the simulation.

1. Reset the simulation, and then select the **Wheel Feeder** and fill your view with it.

2. On the View Selector, go to a top-left view.

3. On the 3D world toolbar, click **View Editor**, and then click + to add a new view. This creates a custom view for the layout.

4. In the 3D world, select the **robot** and fill your view with it, and then create a new view.

5. On the View Selector, go to a top-front-left view, and then create a new view.

6. On the View Selector, go to a top view, and then create a new view.

In total, you should have four views for the layout. You are now ready to create a program for moving the camera of the 3D world during a simulation. This program can be saved with the layout along with its views.
7. On the Home tab, in the Camera group, click **Camera Animator**.

8. In the Camera Animator task pane, add a **View** statement for each of the four views you created in the layout.

![Camera Animator](image)

By default, the transition from one view to the next references simulation time. If you were to run the simulation now, the camera would snap to View4. The goal is to start at the first view, transition to View2 to show the robot picking up a wheel, transition to View3 to view the first machine process, and then transition to View4 at the end.

9. Do all of the following:

   - For View2, set Time to 10 seconds.
   - For View3, set Time to 15 seconds.
   - For View4, set Time to 40 seconds.

![Camera Animator](image)

10. Run the simulation to verify the camera movements, and then reset the simulation.
11. On the Simulation controls, click **Export to Video**.

12. In the Export to Video task pane, set Resolution to **720p**, Video codec to **MP4**, Quality to **High**, and then click **Start Recording**.

13. Save the file, and then wait for the simulation to end and playback the video.

14. Reset the simulation and exit the Export to Video command.
Drawing Controls

The Drawing tab allows you to create 2D drawings of the 3D world and save them with a layout. You also have the option to export and print drawings.

1. Click the Drawing tab. This displays drawings of the layout, including a parts list (BOM), dimensions and annotations. A template is being used to control the scale of drawings and form a print-ready file.

2. Press CTRL+A to select everything, and then delete it.


4. In the Template Import task pane, set Template to Drawing Template A3, and then click Import.

NOTE! Templates are stored in your Documents library. Path is C:\Users\%username%\Documents\Visual Components\4.1\My Templates
Drawings

A drawing is made from the geometry of components and contains lines, points and edges. Standard views create orthographic drawings. You do have the option to select geometry and draw it using either perspective or orthographic projection.

1. In the drawing world, select the template, and then in the Component Properties panel, set Title to Machine tending and Scale to 1:50. This scale value will affect all new drawings.

2. On the Drawing tab, in the Create View group, click Select. This allows you to select what you want to draw from the 3D world.

3. In the Cell Graph panel, mark the #Undefined category as invisible to hide the floor plan lines.

4. On the View Selector, go to a top view and then fill your view.

5. In the 3D world, drag the pointer to draw a selection area around all of the components.

6. In Drawing View, click Generate from orthographic. This creates an orthographic drawing for the top view of the layout. The result is the same if you were to use the Create View > Top command.

NOTE! By default, a drawing is generated as fast as possible, which might affect its quality. For example, there might be some lines missing from the drawing. Backstage there is a Display option called "Generation quality" which can be used to improve drawing quality.
Dimensions

Dimensions allow you to show measured values.

1. On the Drawing tab, in the Dimension group, click **Linear**. This allows you to record the distance between two points.

2. In the drawing world, click a point on the far left edge of the **feeder**. This marks the first endpoint.

3. Now, click a point on the far right edge of the **mill machine**. This marks the final endpoint.

4. Finally, click a point above the drawing to anchor the dimension.
5. Create a new dimension that measures the height of the drawing.

6. Click the **File** tab to go backstage, and then access **Display** options.

7. Set Display accuracy to **2** and then click **OK**. This modifies measured values to show the hundredths place.
Annotations

Annotations allow you to identify parts and other information.

1. On the Drawing tab, in the BOM group, click **Create**. This auto-generates a bill of materials and identifies components in the drawing using balloon annotations. Some components, for example the machines, are not annotated because their BOM property is disabled, thereby excluding them from the bill of materials.

<table>
<thead>
<tr>
<th>ITEM</th>
<th>QTY</th>
<th>NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>Control Enclosure</td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>Conveyor</td>
</tr>
<tr>
<td>3</td>
<td>1</td>
<td>Articulated Robot</td>
</tr>
<tr>
<td>4</td>
<td>1</td>
<td>Basic Feeder</td>
</tr>
<tr>
<td>5</td>
<td>1</td>
<td>Industrial Camera</td>
</tr>
</tbody>
</table>

2. In the drawing world, drag the annotations to reposition them.

3. Click the **drawing**, and then use the Move tool to move the drawing to the right of the bill of materials. The dimensions and annotations also move because they are attached to the drawing.
Printing

Drawings can be sent to a printer or saved to file.

1. On the Drawing tab, in the Print group, click **Drawing**. This takes you backstage to preview the file. By default, the full preview of the drawing is not shown and scaled to fit the dimensions of the paper/template.

2. Set Printer to **Adobe PDF**, and then click **Print**.

3. Save the file, and then verify the drawing is visible in the PDF.

4. On the Navigation bar, click the **Go Back** arrow to exit the print preview screen.
Statistics Dashboard

The Statistics dashboard allows you report and visualize simulation data. For example, you can track how many parts enter and exit conveyors.

1. Click the Home tab, and then in the Statistics group, click Statistics to open the dashboard.

2. In the Statistics 1 tab, double-click the 1-Column 1-Row layout. This allows you to place one chart that occupies the entire area.

3. Under Simple Charts, click Line Chart to add a chart of that type to the placeholder.
4. In the Properties panel, make the **legend** and **title** visible in the chart. By default, the sampling interval is -1. This means the chart will report/update its data based on the global sampling interval defined in the Statistics group > Interval property.

![Properties Panel](image)

5. Under Data Series, set Name to **Input** and then add both conveyors and the three process machines to the Components list.

![Data Series Panel](image)

**TIP!** To add items to a list type property, first expand the list, and then use either the Pick command to directly select an item in the 3D world or the PLUS SIGN (+) to add items from a given list of options.

6. Set Property to **Statistics.PartsEntered**. This is a cumulative property that counts how many parts flow into a container, for example a path. Since the listed components all have a Statistics behavior, the PartsEntered property is an available option. Another thing to mention is that any data series using a Statistics behavior property will automatically refer to the global sampling interval not the interval of its chart.

![Property Setting](image)
7. Run the simulation, verify the chart reports data after 60 seconds, and then reset the simulation. The chart will not report data if the simulation ends at the same time as a reporting interval. For example, if you run the simulation for two minutes then only the first interval will be reported and shown in the chart.

8. Change the runtime of the simulation to **Infinite**, but also give it a warm up time of two minutes.

9. Run the simulation for at least 8 minutes and verify more data is reported in the chart, and then reset the simulation.

**NOTE!** If you reset a simulation, a chart will keep its data. If you start the simulation, a chart clears its data.
10. In the Properties panel, change Type to **Bar**.

11. In the Statistics dashboard, point at the **Straight Conveyor #3** bar to verify how many parts entered its path.

12. In the Statistics dashboard, click **Change Layout**, and then double-click **1-Column 2-Row** to have a layout that stacks two charts on top of one another. Since you are changing to a layout that supports more than one chart, you will not be prompted to confirm the change since no charts have to be deleted.
13. In the 3D world, select the Pro Mill machine, and then in the Statistics dashboard, under Template Charts, click Component State. This will allow you to track the state of the machine, for example how busy and idle it is during the simulation.

14. Run the simulation for at least 8 minutes and verify how the states of the machine update after each 60 second sampling interval, and then reset the simulation. In this case, the data reported in the component state chart is from the last recorded interval. That is, the data is not cumulative. For example, the Pro Mill machine was idle about 40% of the time for the 7 to 8 minute mark.

15. On the Home tab, in the Statistics group, change Interval to 120 seconds.

16. Run the simulation for at least 8 minutes to see if there is any difference in using a larger sampling interval, and then reset the simulation.
Review

In this module you learned the basics of using a Visual Components 4.1 product. You now have the skills and knowledge to interact with objects in both 2D and 3D simulated environments. You also know how to run and record simulations, report statistics and generate 2D drawings. Overall, you learned how to present, visualize and document a manufacturing process using simulation.

In the next module you will learn how to configure new layouts using libraries of components. For example, you will learn how to use a Conveyors library with routing rules to simulate material flow, a Works library to simulate simple and complex processes, and a Machine tending library to simulate machine tending operations.