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OVERVIEW 
 

In this tutorial, you will learn about the Visual Components user interface, features, and basic tasks. The 

primary outcome is to allow users to quickly develop key skills and competencies for using the program. 

You’ll create a layout as shown below that simulates a machine tending process and an assembly 

process involving a human. 

 

Furthermore, you can access the Visual Components Academy to learn more about specific features 

and purposes that fit their simulation needs.  

 

 

  

http://academy.visualcomponents.com/
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1. GETTING STARTED 

Once Visual Components is installed, open the application. 

1.1 HELP DOCUMENT 

To learn more about the Visual Components user interface select the Help tab, where links to Help and 

Reference Documents, Online Support Material, and Social Media can be found.  Pressing F1 opens the 

application’s Help Document as well.  

The Search tool finds tutorials and discussions on the Visual Components academy and Forum sites. 

 

 

1.2 CREATE A BASIC LAYOUT 
 

In this section, you will learn to create a basic layout. Some of the contents will be explained in more 

details later on.  

 

By default, the eCatalog panel is visible in the Home context on the left-hand 

side. There is an Item Display area on the lower-left corner of the panel, which 

filters objects that are shown in the eCatalog.  

 

 

If the eCatalog or one of the other panels is not visible, it is possible to enable 

them through the Windows context.  

 



VISUAL COMPONENTS  [ INTRODUCTION TO LAYOUT CONFIGURATION ] 

 

 
| PAGE 5 OF 34 | © 2021 Visual Components Oy 

 
 

1. Make sure you are in the Home context. In eCatalog panel, open up the smart collection Models 

by Type. Then select PM Flow Components by Visual Components.  

 

2. Drag and drop the Feeder into the 3D world.  (You can also double-click the items. When double-

clicking a component, it is connected automatically to the selected component in the 3D view, if 

possible. Otherwise, the component appears in the world origin.) 

 

3. Select the Conveyors by Visual Components.  

 

4. Drag and drop the Conveyor into the 3D world.  

 

5. Use the PnP tool to move the component on the floor level. Move the conveyor closer to the 

feeder until a green line appears showing that a connection is possible. The line also shows the 

distance and direction, where the connections happen. Move it even closer, until the conveyor 

snaps to the predefined position. Release the mouse button and note that the yellow arrow 

changes to a green arrow, which indicates that the connection is active. 
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Note: The components shown in the 3D world are listed in the Cell Graph panel.  

 

 

 

1.3 RUNNING A SIMULATION 
 

The layout can be tested by running the simulation using the controls in the top center of the 

application. 

 

 

 

 

 

 

 

 

 

1. Run the simulation. 

 

Settings 

Reset 

Run/Pause 

Clock Display 

Speed Display Speed Slider 

Export to PDF/Video/Animation 

Hint: Download a free Visual Components 

Experience app for viewing the animations. 

https://www.visualcomponents.com/products/downloads/
https://www.visualcomponents.com/products/downloads/
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Don’t forget to reset the simulation by clicking the reset button next to the play button! 

2. Check the final result: 

 

 

 

3. View: 

 

 
 

The floating origin in the top left corner of the 3D world indicates the XYZ orientation of the 

current view. Red, Green and Blue (RGB) vector lines represent X-, Y- and Z-axes, respectively. 

 

The origin of the 3D world is indicated by a static origin positioned on the XY plane. The static origin is 

not shown by default, but it can be enabled in the settings: 

 

FILE > Options > Display > World Origin Frame 

  



VISUAL COMPONENTS  [ INTRODUCTION TO LAYOUT CONFIGURATION ] 

 

 
| PAGE 8 OF 34 | © 2021 Visual Components Oy 

1.4 NAVIGATING THE 3D WORLD 
 

Select Standard views using the View Selector in the lower-left corner. The top view can 

be rotated by 90 degrees by clicking multiple times. The bottom view can be accessed 

by double-clicking the “T”. 

 

The 3D world toolbar on the left of the viewport allows you to affect the visuals of the viewport. Use 

the first group to fill the view to all the components or the selected component. 

 

 

To interact with the 3D world’s camera to change the view of the 3D world, use 

the mouse to activate Orbit (Right Mouse Button click, later RMB), Pan (RMB + 

Left Mouse Button, later LMB), Zoom (Scroll+wheel Up/Down or Shift + RMB + 

drag mouse up/down) and Set Center (Ctrl + RMB on geometry or MB on 

geometry Center in 3D View) options with the mouse.  

 

 

Press F11 to toggle full-screen mode on and off. 

To change the default settings of the floor and the grid select FILE > Options > Display. From the display 

menu it is possible, for example, to disable the floor and grid visibility, show or hide the world origin 

frame, among other settings. 

 

 

 

1.5 LAYOUTS 
 

A layout is a file that contains information related to changes made in the 3D world. This includes, but 

is not limited to, components that have been added to the 3D world and their parameter values, for 

example, an object’s location. A layout is always displayed in the 3D world. 

To save a layout click the File tab, and then on the Navigation pane, click Save As. Then select Browse 

to define the location and the name for the output file. The default location is “…\Documents\Visual 
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Components\4.3\My Models” folder for saving both, components, and layouts. All files under that folder 

and its subfolders appear on the My Models collection in the eCatalog. 

Let’s now save the layout that we created before as “Example 

Layout” to My Models. 

Select My Models in the Collections pane. The Item Display area 

is updated to show the layout created in the previous section.   

It is possible to clear a layout by pressing CTRL+N or through the 

toolbar by selecting File > Clear All. 

 

2. BASIC TASKS 
 

Now you know how to set up a layout in the 3D world by adding, moving, and connecting components. 

Now a less basic layout will be created to learn new techniques and review those contents. The final 

result is a layout that demonstrates a robot doing machine tending and a human doing an assembly 

process. Conveyors will be used to transfer parts between stations.  

 

2.1 DELETE AND CLONE COMPONENTS 
 

Components can be copied and pasted in the 3D world using the Copy/Paste commands in the 

Clipboard group of the Ribbon tab, or in the Context menu (RMB click on top of viewport). The keyboard 

shortcuts CTRL + C and CTRL + V can also be used. 

 

Selecting a component (LMB) in viewport opens the 

QuickMenu with clone and delete icons. Cloning the selected 

component does all the three actions at once; it copies, 

pastes, and connects the new component to the original one.  

 

Let’s continue the previous exercise with some new tasks! 

1. Clone the Conveyor using the Clone tool from the Quick menu.  

2. Hold down the CTRL key and select the two conveyors.  

3. Copy and paste the selected components using one of the methods taught (e.g. Ctrl + C, Ctrl + 

V). There are now two conveyor lines in the 3D world and notice how the pasted components 

did not have to be reconnected. 

Delete Clone 
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Note: If you have problems finding a component from the eCat, use the Search tool located on the top 

of the eCat item display.  

 

 

 

 

 

2.2 CREATE COMPONENTS 
 

The Feeder can create any component in the 3D world if it is attached to it. 

1. Expand the Models by Type collection and select type Products and Containers. 

2. Drag and drop the Piston Head and place it somewhere on the 3D world. 

3. Go to the Process tab and click on Products. 
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4. Select VC_Cylinder in the Product Type Editor and on the Properties tab change the name to 

PistonHead. 

 

 
 

 

5. Click on the yellow cube on the right and select the Piston Head component. 
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Run the simulation and check that the feeder is creating PistonHeads. 

 

2.3 PROCESS MODELING 
 

Process modeling allows you to quickly build and simulate machine tending applications using different 

resources and machines. This feature streamlines the layout planning. 

Next, let’s create a machine tending cell. Let’s start by getting the components we need from the 

eCatalog.   
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1. Expand the Models by Type collection and select type PM Flow Components. 

2. Drag and drop the From Conveyor Process into the 3D world and connect it to the end of the 

right conveyor. In this case, the From Conveyor Process acts as an input or location for picking 

up products. 

 

3. Drag and drop the To Conveyor Process into the 3D world. In this case, the To Conveyor 

Process acts as an output or location for placing products. 

4. Connect the To Conveyor Process to the beginning of the right conveyor. 

 

 

 

5. From the collection PM Transport Controller drag and drop the Robot Transport Controller 

into the 3D world, place it close to the From Conveyor Process. A Robot Transport Controller 

manages a robot that is used as a resource for picking and placing components in a machine 

tending process. 

 

 

6. Expand the Models by Type collection and select type Robot positioners from Visual 

Components. 

7. Drag and drop the Robot Floor Track and snap it to the Robot Transport Controller.  
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8. Select both Robot Floor Track and Robot Transport Controller and turn them 90 degrees as 

shown in the image below.  

 

Note: Rotation can be done through the Component Properties panel, using the blue circle from the 

PnP selection or with the Move tool. The Component Properties panel is compatible with the other 

options. Here some examples:  

 

 
 

 

 
 

9. Select Robots from Visual Components on the eCat and Drag and Drop the Generic Articulated 

Robot.  

10. Snap it to the Robot Floor Track. 
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11. Select Machines in the eCat, drag and drop two Parametric five-axis lathe and two Process 

Machine-ProLathe from Visual Component, and place them as it is shown on the image below. 

Notice that the doors have to be located facing the robot.  

 

 
 

 

Note: It is possible to remove or change the position of the chip removal for the Parametric 

five-axis lathe from the Properties panel. 
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1. Go to the Process tab and click on Flow. 

Now we are going to create the flow for the components. 

2. Select the FromConveyor component and click on the label so the flow would get 

actualized. 

 

 
 

3. Select the Robot Controller and click on the ProLathe label, automatically, the flow 

from both machines would be created. 
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4. With the Robot Controller, selected click on the Parametric 5-axis Lathe machine label 

and again the flow would get actualized. 

 

 
 

 

5. Click on the ToConveyor label to complete the flow.  
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1. Run the simulation!  

Do you get this message below in your output panel? Let’s fix it! 

 

2. If you got this message, your robot is too far from the machines and you should drag them closer 

to it. One way to ensure that the robot can 

reach a point is using the Envelope tool. Select 

the Generic Robot and in the Component 

Properties panel, WorkSpace tab, click on 

Envelope, a grey globe appears covering the 

zones that the robot can reach. Use the 

Interact tool from the manipulation tab to 

move the robot along the floor track for 

checking that is also reaching the machines. 

Disable the envelope after this step.  
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Note: Don’t forget to reset the simulation to return the components to the initial position. 

 

 

2.4 INTERIOR FACILITIES 
 

Visual Components eCat provides Interior Facilities and Factory Facilities libraries. These components 

are static components used for enriching the simulation environment with tables, fences, walls, and 

such.  

 

Let’s use some of those components! 

 

 

 

 

1. Expand the Models by Type collection and select type Facilities-Factory. 

 

2. Drag and drop the FenceAndWallBuilder into the 3D world. 

3. Click on Start Drawing and make a closed contour for the fences. During the drawing, if you 

want to undo a line, you can press Undo Line. Once the drawing is finished, press End Drawing 

and then press Populate Components to generate the fences. The image below explains the 

process. 



VISUAL COMPONENTS  [ INTRODUCTION TO LAYOUT CONFIGURATION ] 

 

 
| PAGE 20 OF 34 | © 2021 Visual Components Oy 

 

 

Note: Once the fences are generated, you can delete the FenceAndWallBuilder component from 

the 3D world first by selecting it using LMB and then Delete (This does not delete the fences): 
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Now let’s add the facilities needed for the next part: 

 

4. Expand the Models by Type collection and select type Facilities-Interior. 

5. Drag and drop Table A into the 3D world and place it roughly as shown in the image below. 

 

 

 
 

2.5 MODIFY PROPERTIES 
 

A component’s property can be edited in the Component Properties tab. The design of a component 

determines what parameters are available and the functionality of certain parameters.  

Now let’s do some changes! 

 

1. Select the last conveyor in the line and change its length so that it reaches through the 

fence. 
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2. Select the panel that the Conveyor crosses and change its StandHeight to 1000. 
 

 

 

 
 
 
 
 
 
 
 
Maybe wooden tables are not the best option for an industrial environment. Let’s change the 
material. 
 

3. Select both tables and on the Component properties panel set the Material property to 
Metal. 
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4. Let’s change the height of the tables to 700 
 

 
 
 

2.6 CREATE STATEMENTS 
 

A Process Modeling statement is used for creating and executing specific tasks.  

Now we’ll create a manual assembly cell using the Process Modelling components. Let’s get the 

components from the eCatalog.  
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1. Expand the Models by Type collection and select type PM Transport Controller. 

2. Drag and drop the Human Transport Controller into the 3D world. The location of the controller 

in the scene is irrelevant. 

3. Expand the Models by Type collection and select type PM Resources. 

4. Drag and drop the Human into the 3D world.  

5. Expand the Models by Type collection and select type Products and Containers. 

6. Drag and drop the Piston Rod into the 3D world. 

7. Expand the Models by Type collection and select type PM Warehousing. 

8. Drag and drop the Warehouse Shelf into the 3D world. 

Note: You can show the Shelf and the TopShelf of the Warehouse Shelf from the Options in the 

Component Properties panel: 
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Notice that these components don’t have to be located in a specific position or connected to 

another component.  The Piston Rod is a template for the objects that will be created later. 

 

9. Open the PM Flow Components file. 

10. Drag and drop a From Conveyor Component a Feeder Process and two Process Nodes. 

 

 
 

As you can see from the picture, the Feeder Process is in a random place close to the Shelf Buffer, the 

Process Nodes are located on top of the tables and the From Conveyor Process is located at the end 

of the Conveyor. 

 

 

Now, let’s connect the interfaces! Components in the 3D world can be remotely connected.   
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1. Go to the Home tab, select the Human Transport Controller, and click on Interfaces from the 

Connect Tab. This displays an action pane along with connection editors in the 3D world for 

wiring connections.  

2. Connect the Human Transport Controller with the Human. 

When the is an available connection the component would show in yellow, when the connection is 

done, the component would show in green.  

  

Now let’s change some settings before creating the flow: 

1. Go to the Process tab click on Products -> Flow group #2 -> VC_Can, now change the name from 

VC_Can to PistonRod, and select it following the steps from before. 

 

 
 

2. Click on Processes select FromConveyor and change the name to ToAssembly. 

 

3. Select the Process Nodes and change the names from Process #1 to Assembly and 

FinalAssembly. 

 

 



VISUAL COMPONENTS  [ INTRODUCTION TO LAYOUT CONFIGURATION ] 

 

 
| PAGE 27 OF 34 | © 2021 Visual Components Oy 

 

 

Now let’s create the flow. 

The human is supposed to pick the part from the conveyor, place it in the Process Node, assemble it 

with the piece from the buffer and place it to the other Process Node. 

1. Click on Flow and select Flow Group #1 in the Process Flow Editor, connect ToConveyor to 

ToAssembly.  

If you forget to click on the label, you can select the next process from the flow panel. 

 

 

 

2. Select the Human Transport Controller and connect ToAssembly to Assembly. 
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3. Select Flow Group #2 in the Process Flow Editor and connect the Feeder to the ShelfBuffer. 

Select the Human Transport Controller and Connect the Buffer to Assembly and then to Final 

Assembly. 
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This should be the final flow result:  

 

 

Now let’s modify the statements from Assembly and FinalAssembly. 

 

 

4. Select Processes from the Editor tab and click on Assembly. 

 

5. Select the TransportIn statement and copy these Statement Properties to accept the flow from 

the Piston Head (Flow Group #1): 
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6. Click on statements and add a TransportIn Statement and an Attach Statement so that both 

the Piston Head and the Piston Rod will be merged. 

 

 

7. Now let’s modify the second TransportIn to accept the PistonRod. 

8. After that, attach both components and Transport them out to the FinalAseembly. 
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9. The process is almost finished! Select the FinalAssembly and change the TransportIn to accept 

the new assembly, it is called PistonRod in this case. 

 

 

 
 

 

 

10. Delete the TransportOut and add a Delay and a Remove. 

 

 
 

 

 

And this is the end! Run the layout and check that everything is working! 
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2.7 CONCLUSION 
 

This concludes the tutorial. Please visit Visual Components Academy to access more tutorials, videos, 

and webinars. Also, don’t forget to check our Forum. 

 

 

http://academy.visualcomponents.com/
https://forum.visualcomponents.com/

