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This guide is designed to assist new users in becoming familiar with a Visual Components 
product And the best way to utilize this guide is to first install your software, and then 
complete the steps outlined here. And this document is a companion to a video of the same 
name in the Visual Components Academy, so you may refer to both if necessary. 

This document includes the following topics: 

• Software installation and Customer registration. 

• Accessing the eCatalog and the basics of navigating within the 3D world. 

• Manipulation and interaction with components in the 3D world. 

• Running simulations. 

• Creating images and animations. 

• Creating 2D drawings and statistics charts. 
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1. Getting Started 
1.1. Installation and Setup 

1. Begin by visiting the Downloads page to download and run the installer for your Visual 
Components product. If necessary, refer to the Installation and Licensing User Guide for 
more detailed installation instructions. 

2. Use the Wizard to complete installation, and once completed, click Finish. 

 

3. Start your Visual Components product and use the activation guide to license the 
software. 

 

 

 

https://www.visualcomponents.com/downloads/
https://www.visualcomponents.com/app/uploads/2021/04/user-guide.pdf
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4. Following product activation, use Registration to create a licensing account to manage 
your software licenses and request Customer Support online.  
NOTE! The password you create must be at least eight characters in length, and include 
the following: 

• At least one lower case letter. 

• At least one upper case letter. 

• At least one special character. 

• At least one number. 

 

5. Then start your Visual Components product. 
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1.2. User Interface 

The user interface of a Visual Components product consists of several elements. 

 

1. Menu tabs: where a selection of tools and controls are available. 

2. eCatalog: manage sources of component files and load those components in the 3D 
world. 

3. Cell Graph panel: provides an outline of the current layout in 3D world and options 
for selecting and editing listed items. 

4. Output panel: prints feedback on events, commands, and other actions. 

5. Properties Tabs. 

6. Properties Panel: edit the properties of a selected object. 

7. 3D world: build layouts in the 3D world using components. 

8. Simulation Controls: available from the top of the 3D world, allowing you to start, 
stop, reset, record, and customize a simulation. 

9. Floating Origin: represents the X, Y, and Z axes of the world coordinate system. 

10. 3D world toolbar: control the visuals of the viewport. 

11. View Selector: represents six standard views joined together to form an interactive 
navigation control. 
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1.3. Quick tips on restarting and configuring the User Interface 

Should you ever need to start a project from the beginning, select the File tab, click Clear 
All, and then click Don’t Save. 

 

Or, if you find that the eCatalog and Cell Graph windows that appear on the left in the 
Home tab, move out of their standard position. From the Windows group on the right side 
of the ribbon, click Restore Windows. 
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1.4. Help 

1. Click the Help tab, which displays commands on the ribbon to access offline and online 
help material. 

 

2. Do any of the following: 

• To access the Help file, press F1, or in Help and Reference group on the left, click Help.  

1. It is recommended to review the Getting Started > How It Works section.  

2. Refer to the User Interface section as needed.  

3. The Tasks section contains mini-tutorials or how-to articles. 

• To access online lessons and courses through the Visual Components Academy click 
Academy. It is recommended to complete the Getting Started course and subscribe to 
the Academy to receive notifications via email. 

• To access online support or submit a support ticket at support.visualcomponents.com 
in Online Support Material, click Support.  

1. You can log in using the licensing account you created during registration.  

2. You can use the same licensing account to manage licenses online in the Customer 
Portal at license.visualcomponents.net. 

3. NOTE! If you do not already have a valid maintenance agreement, you can still 
submit a support ticket by emailing support@visualcomponents.com.  

• To ask questions, find answers, and discuss Visual Components products, in the Online 
Support Material group, click Forum to open a web browser and visit the Visual 
Components Forum at forum.visualcomponents.com. It is recommended to register an 
account to upload and download attachments and create and reply to Forum threads.  

1.5. eCatalog 

1. Click the Home tab, which displays a view for building a layout and running simulations 
in the 3D world. 

 

https://academy.visualcomponents.com/
https://academy.visualcomponents.com/courses/getting-started/
https://support.visualcomponents.com/
https://license.visualcomponents.net/
mailto:support@visualcomponents.com
https://forum.visualcomponents.com/
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2. In the eCatalog panel Collections view, you can do the following: 

• Expand Models by Type, a smart collection that uses metadata to group items first by 
type and then by manufacturer. 

• Then scroll down and expand Models by Manufacturer, which groups items first by 
manufacturer and then by type. 

• Both smart collections are hard-coded and reference the eCatalog source in the 
Models folder in the Public Documents on your PC. 

 
• Your eCatalog content is linked to a Models folder in the Public Documents on your PC 

under the following example path: 
C:\Users\Public\Documents\Visual Components\%version%\Models 

• This directory contains a local copy of the Visual Components Web eCatalog. This 
directory is synchronized with the online library every time you start the application. 

• NOTE! Your personal My Models folder is located on your PC under the following 
example path: 
C:\Users\%username%\Documents\Visual Components\%version%\My Models 
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2. Basic Controls 
We will begin by selecting a single component from the eCatalog while learning the basic 
controls. And later, we can try a saved layout, which you can use to run simulations.  

 

2.1. Basic Controls 

Generally, you would use a mouse and keyboard with a Visual Components product. 

1. To load an example component from the eCatalog into the 3D world, click the Home 
tab, and from the eCatalog panel, Collections view, expand Models by Type. And then, 
for example, in the Robots category, select Visual Components. 
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2. Then from Visual Components, double-click on the Generic Articulated Robot to load it 
into the 3D world. 

 

3. Or drag-and-drop the Generic Articulated Robot and use your mouse cursor to specify 
where in the 3D world you would like to place the component. 
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4. To fill your view with the selected robot, from the 3D world toolbar on the left, click Fill 
Selected. 

 

5. Or, if your 3D world view includes multiple components, from the 3D world toolbar on 
the left, click All (Ctrl+F). 
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6. Use the following mouse and keyboard controls to interact with your view in the 3D 
world: 

• To rotate the camera: 
Hold down your right mouse 
button (RMB) and try moving 
your mouse in all directions. 

 
• To pan the camera: 

Hold down your left and right 
mouse buttons (LMB+RMB) 
and try moving your mouse in 
all directions. 

 
• To zoom the camera: 

Rotate your mouse wheel.  
 
Or holding SHIFT, with your 
right mouse button 
(SHIFT+RMB), drag your mouse 
back and forth. 
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7. To set center on an object, such as a robot tool, holding CTRL, right-click on the 
component. Or right-click on the component and select Center in 3D View. 

 

 

2.2. View Selector 

A Floating Origin and View Selector indicates your point of view in the 3D world. 

1. The Floating Origin in the upper left corner of your 3D world view represents the X, Y, 
and Z axes of the world coordinate system. 
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2. The View Selector in the lower-left corner of your 3D world view, represents six 
standard views joined together to form an interactive navigation control.  

• NOTE! The View Selector highlights a standard view if it resembles your current view. 

 
• Top and Down views share the same square: one-click for Top and double-click for 

Down. In Top view, each click will rotate the camera 45 degrees. 

 
• A standard view’s inner and outer edges can be used to select a view adjacent to two 

sides. 
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• The corners of a standard view can be used to select a view adjacent to three sides. 

 

2.3. Controlling Layouts 

Before continuing, you may want to clear your 3D world view of any components. As we 
noted in section 1.3 above, to start from the beginning, select the File tab, click Clear All, 
and then click Don’t Save. 

1. To load an example layout from the eCatalog into the 3D world, click the Home tab, and 
under Models by Type, select Layouts. 
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2. With Layouts selected, search by typing machine, and select the Machine Tending 
layout. Then double-click on the layout icon to load it into the 3D world. 
NOTE! You can also drag-and-drop a layout; however, you cannot use your cursor to 
specify its location in the 3D world, as the layout’s default location is predefined.  

 

3. You should now have the Machine Tending layout loaded into the 3D world. 
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4. NOTE! At this point, you can choose either the Select, PnP (Plug and Play), or Interact 
tools from the Manipulation Group in the Home tab. In this example, we will use the 
PnP tool. 

 

5. In the 3D world, left-click select the robot in the center of the layout. The selection is 
highlighted, and its attributes are displayed in the Component Properties panel over on 
the right. 

 

6. With the robot selected, you can now try adding another machine to the current 
selection. Holding your CTRL key, left-click on another machine to add it to the selection. 
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7. You will now have two components selected. To remove the second machine from the 
selection, holding your CTRL key, left-click on it once more. 

 

8. NOTE! If selected objects have common properties, you can edit them if their values are 
not unique. For example, in the Component Properties panel on the right, Name is a 
default property with a unique value. 
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3. Manipulation Controls 
The Manipulation group on the ribbon contains different modes for manipulating objects. 
Depending on the context of the scene you are in, you may have tools for either selecting, 
moving, connecting, or interacting with components. 

3.1. Manipulation group 

The Manipulation group with up to three individual tools appears in the Home, Process, 
Modeling and, Program tabs.  

 

3.2. Selection 

The Select tool only selects objects in the current context, for example, components in the 
3D world. 

1. On the Home tab, in the Manipulation group, click Select. We will choose the Feeder 
component from the Machine Tending layout in this example. 
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2. To select the Feeder from the layout in the 3D world, drag your cursor to make an area 
selection around it.  

 

3. Then, click the floor to remove the selection. 

 

3.3. Movement 

1. The Move tool displays an all-in-one tool for moving selected components. 
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2. The arrows are for moving a selection along a single axis. 

 

3. The squares are for moving a selection in a plane formed by two axes.  
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4. The arcs are for rotating a selection around an axis.  

 

5. The ring (also known as torus or origin) can directly move a selection to your desired 
location.  
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6. The ring can also be used for snapping a selection to an object in the 3D world. 

 

7. Select the Cell Graph panel from the lower-left corner of the application window. Then 
above from the Machines category, double left-click on Process Machine - ProLathe to 
select the component in the 3D world. 
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8. With the Process Machine - ProLathe from the Machine Tending layout selected, from 
the Home tab in the Manipulation group, select the Move tool, which will appear at the 
origin of the currently selected component. 

 

9. Then in the 3D world, drag the blue square to move the machine along its XY plane. 

 

10. Then press CTRL + Z to undo the last action, returning the machine to its original 
location. 
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3.4. Plug and Play 

The PnP (Plug and Play) tool is used to plug components into one another, creating a 
physical connection, and the plugs are known as interfaces.  

 

Compatible components will snap together at their connected interfaces. A selected 
component shows its interfaces as yellow or green arrows. Yellow indicates an available 
connection, while green indicates an active connection. 

 

1. In the 3D world, from the Cell Graph in the lower-left corner, select the Feeder.  
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2. From the Manipulation group on the Home tab, select the PnP tool, which displays a 
ring around the feeder that you can use to rotate the component in its place. Generally, 
this ring is used to help connect interfaces and deal with angle and distance tolerances 
for establishing connections. 

 

3. In the 3D world, drag the feeder away from its adjacent conveyor to unplug those 
components. The PnP tool allows you to move a selected component freely. 
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4. Then drag the feeder back toward the conveyor until a green arrow points from the 
feeder that snaps to the conveyor. 

 

3.5. Interaction 

The Interact tool is used to jog or move interactive parts of components. For example, you 
can interact with the joints of a robot. 

1. Select the robot in the 3D world, and from the Manipulation group on the Home tab, 
click Interact. The pointer will change to a hand icon when you hover over an interactive 
element in the 3D world. 
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2. Then using the Interact tool, place your cursor over the robot’s joints and try 
manipulating them. 
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3. You can also try manipulating other components in the layout, such as the door of a 
Process Machine - ProLathe. 

 

4. Or try manipulating some of the other elements of a Process Machine - ProLathe. 
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4. Simulation Controls 
The Simulation controls for running and recording simulations are at the top of the 3D 
world. 

• The Play button can start and stop a simulation.  

 
• The Reset button returns a simulation to its initial state and a zero time.  

 
• The Speed factor and slider manage how quickly you run a simulation. 

 

1. From the Simulation controls, click Reset, which returns all components to their initial 
state. For example, the robot’s joints are returned to their initial values. 
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2. Then, on the Simulation controls, click Play. During a simulation, components like the 
Feeder create dynamic components that only exist in the simulation. The components 
generated by the feeder move to the adjacent conveyor because the feeder and 
conveyor are connected and have paths for containing and moving other components. 
This is known as a flow. 

 

3. On the Simulation controls, use the slider to speed up or slow down the simulation. Or 
double-click the slider to reset the speed factor to x 1.0. 
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4. From the Simulation controls, click Reset. The components generated by the feeder 
disappear, whereas other components like the robot remain static and are returned to 
their initial states, as they were when the Machine Tending layout first was loaded into 
the 3D world.  
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5. Recording Controls 
5.1. Images 

The Export Image command allows you to capture images of the 3D world.  

1. To capture an image, you will need to set up a view to appear in your exported image. If, 
for example, your Machine Tending layout view is not centered, use the All (Ctrl+F) 
option from the 3D world toolbar on the left. 

 

2. When centered in your view, the layout will appear small. To enlarge it, place your 
mouse cursor over the robot in the center of the layout, and then use your mouse wheel 
to zoom in until the layout fills your view of the 3D world. 
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3. Then from the Home tab, in the Export group, click Image to display a red boundary in 
the 3D world. Anything inside this red boundary will be captured in the image, except for 
user interface elements. Then from the Export Image panel on the right, select a 
Resolution of 1920 x 1080,  File Format PNG, and Render mode Realistic shaded.  

 

4. You may want to modify the view angle before exporting your image. Refer to the 
mouse and keyboard controls section above for quick tips on manipulating your view. 
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5. Then once you have your view ready, from the lower right corner of the Export Image 
panel, click Export and save the image. 
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5.2. Animations 

The Export to Animation command allows you to record a simulation as an animation that 
can be played through the Visual Components Experience, an app for viewing 3D content 
and experiencing virtual reality (VR).  

NOTE! Visit the Visual Components Experience page for a detailed User Guide and links to 
download the mobile and desktop versions of the Visual Components Experience app.  

1. To begin, from the Simulation controls, click Reset. And then, from the right side of the 
Simulation controls, click Export to Animation. 

 

 

 

 

2. In the Export to Animation task pane, click Start Recording, then select the location on 
your PC where you will save the animation file, and click Save.  
NOTE! The .vcax file is by default saved in the My Animations folder on your PC, example 
path below: 
C:\Users\%username%\Documents\Visual Components\%version%\My Animations 
 

  

https://www.visualcomponents.com/visual-components-experience/
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3. Then when you are ready, click Stop and save. And then click Close from the lower right 
of the application window.  

 

 

 

 

 

6. Drawing Controls 
The Drawing tab allows you to create 2D drawings of the 3D world from the geometry of 
components, and contains lines, points, and edges. You also have the option to export and 
print drawings. Standard views create orthographic drawings. You have the option to select 
geometry and draw it using either perspective or orthographic projection. 

1. With the Machine Tending layout loaded into the 3D world, click the Drawing tab. 

 

2. The Drawing tab displays layout drawings, including a parts list (BOM), dimensions, and 
annotations. A template is used to control the scale of drawings and form a print-ready 
file. In this example, the Machine Tending layout includes a drawing that you can clear 
to create another. So from Drawing Group, click Clear.  
NOTE! If your view does not refresh correctly, displaying an empty view, then left-click 
with your mouse in the view area. 
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3. On the Drawing tab in the Drawing group, click Load Template. Then from the Template 
Import task pane on the right, set Template to Drawing Template A3, and from the 
lower right corner of the window, click Import. 

 

4. If, when importing the template, it does not fill your view, use the All (Ctrl+F) option 
from the 3D world toolbar on the left. 
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5. Then to create a drawing from the Create View Group, click, for example, Top. 
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6. In this example, you may wish to increase the scale of the drawing. From the Drawing 
Properties panel on the right, edit the Scale value from 1:100 to 1:50 and click Enter. 
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7. NOTE! To modify the scale of a drawing, you must first select it. If the Drawing 
Properties panel does not appear, first check that the drawing is selected as shown on 
the right in the image below.  

 

8. Then to give your drawing a title, first select the template. Place your mouse cursor over 
the lower-left corner of the template, and left-click on it until you see the floating origin 
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appear. And from the Component Properties panel on the right, add an example Title 
such as Machine Tending, and again edit the Scale value to 1:50. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

9. Then to complete your drawing from the BOM group above, click Create.   
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10. And finally, to print or create a PDF file of your drawing, from the Drawing tab, over on 
the right in the Print group, click Drawing.  
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7. Statistics Dashboard 
The Statistics dashboard allows you to report and visualize simulation data. For example, 
you can track how many parts enter and exit conveyors.  

For more detailed information on generating statistics refer to the Using Statistics 
Templates lesson in the Visual Components Academy. Or from the Help File in Tasks, 
Components refer to Reporting statistics.  

1. With the Machine Tending layout loaded into the 3D world, click the Home tab, and 
then from the Statistics group, click the Statistics button to launch the Statistics panel.  

 

2. The Machine Tending layout already includes a Statistics 1 tab in the Statistics panel in 
this example. 

 

https://academy.visualcomponents.com/lessons/using-statistics-templates/
https://academy.visualcomponents.com/lessons/using-statistics-templates/
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3. You can freely edit the size and position of the Statistics panel. So for illustrative 
purposes, we will reduce its size and place it over the layout in the 3D world.  

v  

4. We can retain the existing Statistics 1 tab layout, and to create a new example, click the 
green + Add new tab button. 
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5. Then from Choose Layout, select 2-Column 1- Row, and click Create to add a new tab. 

 

6. And then, to select components from the 3D world to include in your Statistics 2 tab, 
click and drag the Statistics panel downwards. 
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7. To create a chart displaying the utilization of the three machines included in the 
Machine Tending layout, hold your CTRL key, and left-click to select each of the three 
machines, and from the Statistics panel, select Utilization. 
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8. Then to view data on how many components are generated by the Machine Tending 
layout, left-click to select the output conveyer on the right side of the layout, and from 
the Statistics panel, select Production Rate. 
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9. Before running the simulation, notice that from the simulation controls, the simulation 
time is set to 0:00:00. However, we should still use the Reset option to ensure that all 
the components in the Machine Tending layout are set to their initial states. 

 

10. Then to start the simulation, from the simulation controls, click Play to record some 
statistics based on an Interval of 60 seconds as specified in the Statistic group in the 
ribbon above. 
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11. Then, as you watch the simulation play, you can see the statistics recorded based on the 
specified interval of 60 seconds. 
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12. And remember that when viewing your statistics, you can move and resize the Statistics 
panel window as you wish. 
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