Introduction to Layout Configuration

Visual Components Product Family 4.1
OVERVIEW

In this tutorial, you will learn about the Visual Components user interface, new features, and basic tasks. The primary outcome is to allow users to quickly develop key skills and competencies for using the program.

You’ll create a layout as the one shown below that simulates a machine tending process and an assembly process involving a human.

Furthermore, you can access the Visual Components Academy to learn more about specific features and purposes that fit their simulation needs.
TABLE OF CONTENTS

Overview .......................................................................................................................... 2
1. Getting Started .......................................................................................................... 4
   1.1 Help Document ....................................................................................................... 4
   1.2 Create A Basic Layout .......................................................................................... 4
   1.3 Running A Simulation .......................................................................................... 6
   1.4 Navigating The 3D World ..................................................................................... 7
   1.5 Layouts .................................................................................................................. 8
2. Basic Tasks .................................................................................................................. 9
   2.1 Delete And Clone Components ............................................................................. 9
   2.2 Attach Components .............................................................................................. 10
   2.3 Machine Tending Library ..................................................................................... 11
   2.4 Connect Interfaces ............................................................................................... 15
   2.5 Interior Facilities .................................................................................................. 17
   2.6 Modify Properties ................................................................................................. 20
   2.7 Works Library ....................................................................................................... 23
   2.8 Conclusion ............................................................................................................. 29
1. GETTING STARTED

Once Visual Components is installed, open the application.

1.1 HELP DOCUMENT

To learn more about the Visual Components user interface select the Help tab, where links to Help and Reference Documents, Online Support Material and Social Media can be found. Pressing F1 opens the application’s Help Document as well. Search tool finds tutorials and discussions on the Visual Components academy and Forum sites.

1.2 CREATE A BASIC LAYOUT

In this section, you will learn to create a basic layout. Some of the contents will be explained in more detail later on.

By default, the eCatalog panel is visible in the Home context on the left-hand side. There is an Item Display area on the lower left corner of the panel, which filters objects that are shown in the eCatalog.
1. Make sure you are in the Home context. In eCatalog panel, open up the smart collection Models by Type. Then select Feeders by Visual Components.

2. Drag and drop the Shape Feeder into the 3D world. (You can also double-click the items. When double-clicking a component, it is connected automatically to the selected component in the 3D view, if possible. Otherwise, the component appears in the world origin.)

3. Select the Conveyors (New) by Visual Components.

4. Drag and drop the Conveyor into the 3D world.

5. Use the PnP tool to move the component on the floor level. Move the conveyor closer to the feeder until a green line appears showing that a connection is possible. The line also shows the distance and direction, where the connections happen. Move it even closer, until the conveyor snaps to the predefined position. Release the mouse button, and note that the yellow arrow changes to green arrow, which indicates that the connection is active.
Note: The components shown in the 3D world are listed in the Cell Graph panel.

1.3 RUNNING A SIMULATION

The layout can be tested by running the simulation using the controls in the top center of the application.

1. Run the simulation.

Hint: Download a free Visual Components Experience app for viewing the animations.
Don’t forget to reset the simulation by clicking the reset button next to the play button!

2. Check the final result:

3. View:

The **floating origin** in the top left corner of the 3D world indicates the XYZ orientation of the current view. Red, green and blue (RGB) vector lines represent X-, Y- and Z-axes, respectively.

The origin of the 3D world is indicated by a **static origin** positioned on the XY plane. The static origin is not shown by default, but it can be enabled in the settings:

FILE > Options > Display > World Origin Frame

**1.4 NAVIGATING THE 3D WORLD**

Select **Standard views** using the **View Selector** in the lower left corner. The top view can be rotated by 90 degrees by clicking multiple times. The bottom view can be accesses by double clicking the “T”.
The **3D world toolbar** on the left of the viewport allows you to affect the visuals of the viewport. Use the first group to fill the view to all the components or the selected component.

To interact with the 3D world’s camera to change the view of the 3D world use the mouse to activate **Orbit** (Right Mouse Button click, later RMB), **Pan** (RMB + Left Mouse Button, later LMB), **Zoom** (Scroll+wheel Up/Down or Shift + RMB + drag mouse up/down) and **Set Center** (Ctrl + RMB on geometry or MB on geometry Center in 3D View) options with the mouse.

Press **F11** to toggle full screen mode on and off.

To change the default settings of the floor and the grid select **FILE > Options > Display**. From the display menu it is possible, for example, to disable the floor and grid visibility, show or hide the world origin frame, among other settings.

### 1.5 LAYOUTS

A layout is a file that contains information related to changes made in the 3D world. This includes, but is not limited to, components that have been added to the 3D world and their parameter values, for example, an object’s location. A layout is always displayed in the 3D world.

To save a layout click the **File** tab, and then on the Navigation pane, click **Save As**. Then select **Browse** to define the location and the name for the output file. The default location is “…\Documents\Visual Components\4.1\My Models” folder for saving both, components and layouts. All files under that folder and its subfolders appear on the **My Models** collection in the **eCatalog**.
Let’s now save the layout that we created before as “Example Layout” to My Models.

Select My Models in the Collections pane. The Item Display area is updated to show the layout created in the previous section.

It is possible to clear a layout by pressing CTRL+N or through the toolbar by selecting File > Clear All.

2. BASIC TASKS

Now you know how to set up a layout in the 3D world by adding, moving and connecting components. Now a less basic layout will be created to learn new techniques and review those contents. The final result is a layout that demonstrates a robot doing machine tending and a human doing an assembly process. Conveyors will be used to transfer parts between stations.

2.1 DELETE AND CLONE COMPONENTS

Components can be copied and pasted in the 3D world using the Copy/Paste commands in the Clipboard group of the Ribbon tab, or in the Context menu (RMB click on top of viewport). The keyboard shortcuts CTRL + C and CTRL + V can also be used.

Selecting a component (LMB) in viewport opens up the Quickmenu with clone and delete icons. Cloning the selected component does all the three actions at once; it copies, pastes and connects the new component to the original one.

Let’s continue the previous exercise with some new tasks!

1. Clone the Conveyor using the Clone tool from the Quickmenu.
2. Hold down CTRL key and select the two conveyors.
3. Copy and paste the selected components using one of the methods taught (e.g. Ctrl + C, Ctrl + V). There are now two conveyor lines in the 3D world and notice how the pasted components did not have to be reconnected.

Note: If you have problems finding a component on the eCat use the search tool located on the top of the eCat item display.

2.2 ATTACH COMPONENTS

The Shape Feeder can create any component in the 3D world if it is attached to it.

1. Expand the Models by Type collection and select type Products and Containers.
2. Drag and drop the PistonHead and place it somewhere on the 3D world.
3. Click on Attach from the Hierarchy tab and select the blue circle of the Shape Feeder.
Note: This is a special type of attachment and the part is automatically detached after first simulation run. You’ll see later a more common use of the attach tool.

Run the simulation and check that the feeder is creating PistonHeads.

2.3 MACHINE TENDING LIBRARY

Visual Components Machine Tending library allows you to quickly build and simulate machine tending applications using different resources and machines. The library is flexible and can be used with other component libraries, for example Works and Conveyors.
Next let’s create a machine tending cell. Let’s start by getting the components we need from the eCatalog.

1. Expand the Models by Type collection and select type **Machine Tending**.
2. Drag and drop the **MachineTending Inlet** into the 3D world and connect it to the end of the right conveyor. Machine Tending Inlet acts as an input or location for picking up products.
3. Drag and drop the **MachineTending Outlet** into the 3D world. Machine Tending Outlet acts as an output or location for placing products.
4. Connect the Outlet to the end of the right conveyor.

5. From the collection Machine Tending drag and drop the **Machine Tending Robot Manager** into the 3D world, place it close to the Inlet. A Robot Manager controls a robot that is used as a resource for picking and placing components in a machine tending process.

6. Expand the Models by Type collection and select type **Robot positioners** from Visual Components.

7. Drag and drop the **Robot Floor Track** and snap it to the Machine Tending Robot Manager.

8. Select both Robot Floor Track and Machine Tending Robot Manager and turn them 90 degrees as shown on the image below.
Note: Rotation can be done through the Component Properties panel, using the blue circle from the PnP selection or with the Move tool. The Component Properties panel is compatible with the other options. Here some examples:

9. Select Robots from Visual Components on the eCat and Drag and Drop the **Generic Articulated Robot**.

10. Snap it to the Robot Floor Track.

11. Select Feeler from Machines on the eCat, drag and drop two **TC20** feelers and two **FTC150** feelers and place them as it is shown on the image below. Notice that the doors have to be located facing the robot.
2.4 CONNECT INTERFACES

Components in the 3D world can be remotely connected.

1. Select the **Machine Tending Robot Manager** and click on **Interfaces** from the **Connect Tab**. This displays an action pane along with connection editors in the 3D world for wiring connections.

2. Connect the Machine Tending Robot Manager with the machines, the Inlet and the Outlet with the blue wire.
Yellow means available connection.

Grey means no available connection.

Blue is used for the selected component interface.

Green means an active connection.

The wire shows the endpoints of the connections.
3. Run the simulation!
   Do you get this message below in your output panel? Let’s fix it!

```
Output
Controller GenericRobot::Controller: Target unreachable.
```

4. If you got this message, your robot is too far from the machines and you should drag them closer to it.
   One way to ensure that the robot is able to reach a point is using the **Envelope** tool. Select the Generic Robot and in the Component Properties panel, WorkSpace tab, click on **Envelope**, a grey globe appears covering the zones that the robot can reach. Use the Interact tool from the manipulation tab to move the robot along the floor track for checking that is also reaching the feelers. Disable the envelope after this step.

![Simulator Interface](image.png)

**Note:** Don’t forget to reset the simulation to return the components to the initial position.

### 2.5 INTERIOR FACILITIES

Visual Components eCat provides Interior Facilities and Factory Facilities libraries. These components are static components used for enriching the simulation environment with tables, fences, walls and such.

Let’s use some of those components!
1. Expand the Models by Type collection and select type Factory Facilities.

2. Drag and drop the **Fence Creator** into the 3D world and place it in the middle of the layout. As it is shown on the image below. The default size is too small. A bigger structure is needed.

3. Go to Component Properties and change the floor length and floor width to 8000 and then click on BuildFences.
Note: If you select any of the panels from the fence you’ll see that is attached to the floor structure. In this case, attach changes the hierarchy structure of the components in the world. The parent object affects child objects, yet child objects do not necessarily affect the parent object. For example, the panels move if the floor is moved. The panels would also be deleted if the floor beneath it was deleted. However, deleting any of the panels would not delete the floor and it would not move if the panels were translated elsewhere in the 3D world.

Notice that it happens the same with the generic robot, the robot floor track and the controller.

Now let’s add the facilities needed for the next part:

4. Expand the Models by Type collection and select type Interior Facilities.
5. Drag and drop the **Storage Shelf** and the **Table A** into the 3D world and place them roughly as shown in the image below.

![3D world with Storage Shelf and Table A](image)

### 2.6 MODIFY PROPERTIES

A component’s property can be edited in the Component Properties tab. The design of a component determines what parameters are available and the functionality of certain parameters. Now let’s do some changes!

1. Select the last conveyor in the line and change its length so that it reaches through the fence.

![Component Properties interface](image)
2. Select the panel that the Conveyor cross and change its StandHeight to 1000.

After running the simulation, you can notice that the robot places the pistons in the machines. Let’s specify the process order through the machines.

3. Select the Machines on the left (hold CTRL to multi select them) and change the ProcessIndex to 1.
4. Repeat the same process with the machines on the right but change the ProcessIndex this time to 2.

Now run the simulation and check that the robot places the piston in one of the machines on the left and then one of the machines on the right.
Maybe wooden tables are not the best option for an industrial environment. Let’s change the material.

5. Select both tables and on the Component properties panel set the Material property to *Metal*. 
2.7 WORKS LIBRARY

The **Works library** can be used for configuring simple and complex simulation processes.

A **Works Process** component is used for creating and executing specific **tasks**. A **Works Task Controller** is used for managing the execution of those tasks. As a result, a layout with a **Works Process** component requires one and only one **Works Task Controller**.

Now we’ll create a manual assembly cell using the Works library components. Let’s get the components form the eCatalog.
1. Expand the Models by Type collection and select type **Works**.
2. Drag and drop the **Works Task Control** into the 3D world. The location of the controller in the scene is irrelevant.
3. Expand the Models by Type collection and select type **Works Resources**.
4. Drag and drop the **Works Human Resource** into the 3D world.
5. Expand the Models by Type collection and select type **Product and Containers**.
6. Drag and drop the **Piston Rod** and the **Piston Shaft** into the 3D world.

Notice that these components don’t have to be located in a specific position or connected to another component. The **Piston Rod** and the **Piston Shaft** are the templates for the objects that will be created later.

7. Expand the Models by Type collection and select type **Works**
8. Drag and drop the **Works Process** from Works folder and Plug’n’Play it together with the conveyor reaching trough the fence. Remember to use PnP tool for snapping components together.
9. Now, Drag and drop another **Works Process** from Works folder and change its HeightOffset to 750 and copy it three times. Place the Works Process in similar positions as the picture below.
10. For the Works Process connected with the Conveyor select Presets from Components Properties.

11. Select the **EndOfConveyorStation** option and type in “human” as the **FeedTask**. Click on **Set**. Now the human will know to pick the PistonHeads from the Conveyor.

12. Works Process components located on the storage shelf will act as infinite sources of components. The one on the left will be feeding Piston Shaft and the one on the right will feed Piston Shafts. Select **Presets** again but choose **Source this time** and copy the instructions on the pictures below. Don’t forget to press **Set**. (words “Piston Rod” and “Piston Shaft” are the names of the product components we placed in the layout earlier and their names need to be typed in exactly as their names appear in the layout.)
Let’s check that the parts are being created. Don’t worry about the exclamation signs on the other Works Process components.
13. For the Works Process component located on the table select Presets again but choose HumanProcessStation at this time and type in the instructions as shown in the picture below. This is the station where the human will assemble all the components together. The final part, the PistonAssy.

Now the human is assembling the parts, but another step is needed, palletizing the PistonAssy.

Run the simulation and check that the parts are being assembled. Don’t forget to reset the simulation!

Apart from presets, task can be created separately in the Default tab.
14. Now select the last Works Process and click on Task, we want the human to place the parts to the other table so let’s create a NeedPattern task as it’s shown on the picture.

![Image of NeedPattern task creation](image1)

15. Add then a Remove task.

![Image of Remove task](image2)

16. Check that the InsertNewAfterLine panel looks like the picture below.

![Image of InsertNewAfterLine panel](image3)
And this is the end! Run the layout and check that everything is working!

2.8 CONCLUSION

This concludes the tutorial. Please visit Visual Components Academy to access more tutorials, videos and webinars. Also, don’t forget to check our Forum.